1. NOTICE: If you are using Fabrik and update to Joomla 3.10, you will need to update to Fabrik 3.10. And, if you are using Fabrik, do not upgrade to Joomla 4, we do not have a supported version ready for release. More information on a release date coming soon. Also, please note that Fabrik 3.10 will not install on any Joomla sites less than 3.8.
    Dismiss Notice

Hidden element can't be made to show

Discussion in 'Standard Support' started by jimkeane, May 19, 2015.

  1. jimkeane

    jimkeane Member

    Level: Community
    Hello all,

    Not sure if it is just my install (Joomla 3.4.1 / Fabrik 3.3.2 - vanilla no GitHub) but if I set an element or group to hidden it won't then show even when polled to do so via JS conditions.

    If I include JS conditions to hide the element onload it works, provided the element/group itself is not set to hidden.
    [​IMG]

    Annoyingly the element/group is seen briefly on load unless it is hidden, but if you do set it to hidden it remains so ignoring the JS!

    This seems odd, is there a fix? :)
     
  2. jimkeane

    jimkeane Member

    Level: Community
    Friendly bump :)
     
  3. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Setting an element or group to "hidden" in it's settings is a "sticky" thing.

    If you want to be able to control visibility with the JS, reverse the login in your "on load" event. Don't hide the element / group in settings, instead test to see if you need to hide it on load in the JS.

    -- hugh
     
  4. jimkeane

    jimkeane Member

    Level: Community
    Many Thanks Hugh, this does work, but the items hidden on load are still visible briefly immediately after loading. Is there a fix for this?

    Best wishes,

    Jim
     

Share This Page