1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Problem with Field type element with Decimals format

Discussion in 'Community' started by enrb, May 20, 2019.

  1. enrb

    enrb New Member

    Level: Community
    I have this problem, I have a field of type Field with decimal format where I have enabled the number format to be able to display the number with the comma as a decimal separator and when I go to compile the data in the form it works correctly.
    However, when I enter the list for editing, the field in question appears to me empty on the screen and if I save it then it deletes the previously set value from the database.

    Is it a fabrik problem? or am I the one who stole some settings?
     
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I can't replicate this, number format seems to work OK for me.

    Under "Formatting" do you have "Format" set to "Decimal"?

    What decimal and thousand separators are you using?

    Do you have a format string enabled?

    -- hugh
     
  3. enrb

    enrb New Member

    Level: Community
    I have the problem with the following settings:


    as input type in advanced I have already put "number"
    In formatting format I put "Decimals"
    Full length I put "11"
    Decimal length I put "2"
    "Yes" number format
    thousands separator =. (point)
    decimal separator =, (comma)




    The first time I fill out the form, everything is OK, and even in the list I see the data entered, but when I click on edit, the field in question does not show me the value stored ...
     

Share This Page