1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

PHP 7.3 ok with default Fabrik 3.9

Discussion in 'Community' started by mattsh, Apr 2, 2020.

Thread Status:
Not open for further replies.
  1. mattsh

    mattsh Member

    Level: Community
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    It depends if the "critical" code parts are used ...
    Download Fabrik3.9 is pretty old, there are several fixes for PHP versions in GitHub meanwhile.

    I have sites with PHP7.3 and Fabrik3.9 without issues ( you have to make sure to have Joomla's error reporting off so you won't get notices and warnings breaking JSON answers).

    But at least one site I had to reset to PHP7.1

    After a GitHub update you can e.g. delete the mpdf library (in libraries\fabrik\vendor) if you don't use it;), this will save you about 98MB (unzipped).
    Or create you upload zip without the mpdf folder.
     
    mattsh likes this.
  3. mattsh

    mattsh Member

    Level: Community
    Thanks for your answer @troester , guess I have to test and see how many "critical" parts I use.

    Regards
    Matt
     
Thread Status:
Not open for further replies.

Share This Page