1. NOTICE: If you are using Fabrik and update to Joomla 3.10, you will need to update to Fabrik 3.10. And, if you are using Fabrik, do not upgrade to Joomla 4, we do not have a supported version ready for release. More information on a release date coming soon. Also, please note that Fabrik 3.10 will not install on any Joomla sites less than 3.8.
    Dismiss Notice

Navigation in detailed view for 1.0.5?

Discussion in 'Subscriber Support' started by belindab, Nov 23, 2007.

Thread Status:
Not open for further replies.
  1. belindab

    belindab New Member

    Level: Standard
    Hi Rob,
    You mentioned that you had added the porting of this feature from 2.0 to 1.0 into the new unfuddle system, but I can't find the task list anywhere, only the details of the SVNs. (see your note in http://fabrikar.com/index.php?option=com_smf&Itemid=9&topic=1523.0 the link you gave jsut takes me to the login.

    I am really keen to have this capability and wanted to get a clue as to where it is in the list of things to do, if possible?
    Happy Thanksgiving!
    Belinda
     
  2. rob

    rob Administrator Staff Member

    Level: Community
    Hi Belinda

    Hugh is working on a component that will allow people to view and submit tasks to the tracker, we will hopefully have an announcement later on this week regarding that.
     
  3. rob

    rob Administrator Staff Member

    Level: Community
    a first working version of the page navigation has been added to the svn today.
    To enable it your templates need to have

    Code (Text):

    <div id="fabrikScroller"></div>
     
    placed where you want the navigation to appear on your form or view only page.

    Then edit your form and under the "templates" tab select "yes" for the new "Include scroll navigation" option

    let me know how you get on

    Rob
     
  4. belindab

    belindab New Member

    Level: Standard
    Hi Rob,
    I have uploaded the files from the latest SVN, added the div to my template and set the scroller option for the form. I get the Prev /Next text showing up at the bottom of the form, but nothing happens when you click on it.
    Did I miss something?
    http://eucalyptus-passion.com/index.php?option=com_fabrik&task=viewTableRowDetails&tableid=5&fabrik=3&rowid=51&Itemid=91

    I tried it out with the other templates in case it was something I had omitted in mine, with the same result.

    It would be great if I can get this functioning as we are just about ready to launch the site.
    Thanks,
    Belinda
     
  5. rob

    rob Administrator Staff Member

    Level: Community
  6. belindab

    belindab New Member

    Level: Standard
    Hi Rob,

    Have just discovered that there are two different behaviours going on: If you click on the Latin name, then you go to what used to be the editable form, but - if you do not have edit capability - now is the form with the navigation. If you click on View, then the navigation links are there, but they don't function.

    Following the latin name link - as a visitor - does work to get the next record, which displays ok but moving to another record the photo does not display (if there is one), the icons are replaced by text, there is no description field and the character for degrees is replaced by ? Same thing occurs if you go back to the one you entered on.

    Hope this makes sense, as I've edited it a couple of times as I have discovered more.

    Regards,
    Belinda
     
  7. belindab

    belindab New Member

    Level: Standard
    Also, it would be cool if this nav keeps the same style as elsewhere, i.e. like the pagenav table, rather than having to be styled independantly.

    B
    x
     
  8. rob

    rob Administrator Staff Member

    Level: Community
    hi

    Think ive fixed the erroneous link and Ive added a "pagenav" span around the scroller links which should make it stlyed the same as elsewhere

    Cheers
    Rob
     
  9. belindab

    belindab New Member

    Level: Standard
    Hi,
    The styling is good. Link works to start with but still got problems with the content display after the intial record is displayed, and when you have followed the View link it doesn't go beyond the first record at all.
    For the moment I have commented the scroller out, as I am expecting my client to launch the site and I want everything to be working.
    Then we are running a photography course http:www.imagefrance.co.uk/ so I will not have any time to work on this again until after 8th December.
    I'll get back to you after that point and see where things stand.

    Thanks for your help to date, we are overall very pleased with the fabrik component, it has largely achieved what we set out to do and the support from you and Hugh has been great.
    Regards,
    Belinda
     
Thread Status:
Not open for further replies.

Share This Page