1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Can't have two forms on 1 page

Discussion in 'Standard Support' started by JackGoa, Sep 5, 2018.

  1. JackGoa

    JackGoa Member

    Level: Community
    On some of my sites I sometimes end up having two different forms on one page. Not sure which update caused this, but it must have been one of the latest ones.

    I've noticed, on these pages, if you have two different forms on one page, they'll both default to the second one on the page.

    So for instance, I have a quote form and at the bottom of the page a subscribe form. In this case, the subscribe form will also display where the quote form is supposed to display. So it displays in two places, the one at the top being replaced by the a duplicate of the second one.

    Simply unpublishing one of them solves the problem, but not the ideal solution.

    It never used to be like this in the past.
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    How do you call these forms?
    Two content plugins
    or a standard call via menu + a form module
    or...?
     
  3. JackGoa

    JackGoa Member

    Level: Community
    both via form modules.
     
  4. troester

    troester Well-Known Member Staff Member

    Level: Community
    I can't replicate, two form modules are shown correctly on my site.

    Do you have caching enabled?

    BTW: this is Fabrik3.0/J2.5 forum
     
  5. JackGoa

    JackGoa Member

    Level: Community
    I've had it happen on 2 sites now. Cachimg enabled yes. Have cleared cache, etc.

    Oops, not sure how I ended up in the wrong forum. Should be j3.
     
  6. troester

    troester Well-Known Member Staff Member

    Level: Community
    Which cache level?
    Progressive says "Progressive level (default): faster, bigger system cache, includes module renderers cache"
    What happens without caching?

    There were some changes related to caching in J!3.8.12.

    Are you running a recent Fabrik GitHub?
     
  7. JackGoa

    JackGoa Member

    Level: Community
    No I have Conservative enabled.

    Haven't tried with caching switched off.

    I noticed. Had a helluva bad time with extensions and templates.

    Using Helix3 FYI. Might have something to do with it?
     
  8. troester

    troester Well-Known Member Staff Member

    Level: Community
    No, no template issue.

    I can replicate with caching = conservative (J!3.8.12, latest GitHub).
    Seems this is J!3.8.12 related.
    Can you confirm this Joomla version?
     
  9. JackGoa

    JackGoa Member

    Level: Community
    Yes it's 3.8.12.
    Think I updated from Github last week.
     
  10. JackGoa

    JackGoa Member

    Level: Community
    I notice now on one of my older sites on a menu item that links straight to a fabrik form, the page display is all messed up. When I switch off Conservative Caching, it comes right, but as soon as I switch it back on, it gets messed up again. Almost like it's not reading the CSS file properly or something.
     
  11. troester

    troester Well-Known Member Staff Member

    Level: Community
    This is with caching on + a form module?
    I can see this, too.
     
  12. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I'll take a look.

    -- hugh
     
  13. JackGoa

    JackGoa Member

    Level: Community
    This specific one is a link straight to a form, not a module. Also Helix3 template.
     
  14. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    JackGoa likes this.
  15. JackGoa

    JackGoa Member

    Level: Community
    Thanks Hugh. That seems to have fixed it on both counts. Two modules on one page are each displaying their configured forms and also the link directly to a form displays properly now.

    I've cleared the cache and refreshed a few times to make sure.
     
    cheesegrits likes this.

Share This Page